If you want to get Eclipse up and running on OS X Yosemite without having to install the legacy Java SE6 environment then this article talks you through a simple solution to get this working on Java 8.